Results 1 to 1 of 1

Thread: Final Fantasy XIV Alpha Beta System Requirement Un

  1. #1
    Still learning the ropes Reputation: 10

    Join Date
    Apr 2010
    Rep Power

    Smile Final Fantasy XIV Alpha Beta System Requirement Un

    Square Enix had updated Final Fantasy XIV Japanese official site yesterday and released the system requirement for FFXIV alpha beta test. The requirement may be adjusted before the launch of Final Fantasy XIV.

    FFXIV beta test system requirement:


    Windows XP SP3

    Windows Vista 32-bit/64-bit SP2

    Windows 7 32-bit/64-bit


    Intel Core 2 Duo (2.4GHz)

    AMD Athlon X2 (2.4GHz)


    Windows XP: 1.5GB

    Windows Vista/Windows 7:2GB

    Secondary storage:

    10GB for installation

    10GB for installation content and extra update

    Display adapter:

    NVIDIA GeForce 8800 or higher, memory 512MB

    Radeon HD 2009 or higher, memory 512MB


    DirectSound compatible (DirectX 9.0)

    More details are here .

    More interesting and richer contents are here:

    Any remark is available here without register :
    Last edited by GMBsva; 04-30-2010 at 10:13 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts